If you already had Apache2 installed with PHP4 as a module, you must disable that module now because suPHP uses the CGI version of PHP to work (if you don’t know if you have PHP4 installed as module, you can also run this command – it doesn’t hurt):

a2dismod php4

Do the same for PHP5 if you have the PHP5 module installed (the official Debian Sarge repositories don’t have PHP5 packages, however it’s possible that you installed third-party PHP5 packages like those from http://www.dotdeb.org):

a2dismod php5

Then restart Apache:

/etc/init.d/apache2 restart

Post By Editor (2,827 Posts)

Website: →

Connect