To display the running-configuration, type the following command in privileged EXEC mode:

Router#show running-config

To display the startup-configuration that is stored in NVRAM, type the following command in privileged EXEC mode:

Router#show startup-config

The following is the show running-config output from the example used in the Router Configuration section.

Current configuration:
!
version 11.2
!
hostname cisco
!
enable password cisco
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
!
interface Serial0
 ip address 20.2.2.2 255.0.0.0
!
router rip
 network 10.0.0.0
 network 20.0.0.0
!
ip route 0.0.0.0 0.0.0.0 20.2.2.3
!
line vty 0 4
 password telnet
 login
!
end

When displaying a configuration, the exclamation marks (!) function as line separators to make reading easier. Referring to the above example, notice how commands entered at the interface configuration level appear indented underneath the respective interface (e.g. interface Ethernet0). Likewise, commands entered underneath the routing engine configuration level appear indented underneath the routing engine (e.g. router rip). Global level commands are not indented. This type of display allows a user to easily identify which configuration parameters are set at the global configuration level and which are set at the various configuration sub-levels.

Post By Gishore J Kallarackal (2,121 Posts)

Gishore J Kallarackal is the founder of techgurulive. The purpose of this site is to share information about free resources that techies can use for reference. You can follow me on the social web, subscribe to the RSS Feed or sign up for the email newsletter for your daily dose of tech tips & tutorials. You can content me via @twitter or e-mail.

Website: → Techgurulive

Connect